CRUX

Welcome to CRUX bug tracking.
Tasklist

FS#646 - timeline: git commits with date in the past breaks timeline

Attached to Project: CRUX
Opened by Juergen Daubert (jue) - Tuesday, 07 September 2010, 10:04 GMT
Last edited by Thomas Penteker (teK) - Wednesday, 04 September 2013, 19:16 GMT
Task Type Bug Report
Category website
Status Closed
Assigned To Thomas Penteker (teK)
Operating System CRUX
Severity Low
Priority Normal
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If commits to git get pushed to crux.nu a day after they has been committed locally our timeline (http://crux.nu/Main/Timeline) goes wild and lists the commits over and over again. See the timeline of 2010-09-06 for example.

I assign this bug to Simone, the author of the timeline, maybe he has the time and energy to look at this issue, and Thomas, who is our infra guy currently.

This task depends upon

Closed by  Thomas Penteker (teK)
Wednesday, 04 September 2013, 19:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  Closed for now.
Comment by Jose V Beneyto (sepen) - Saturday, 11 September 2010, 08:36 GMT
well, apart from solving problems to insert into the database (maybe with a trigger or better schema) can be a small fix in the script that displays the records (timeline.php), yes I know that is not a solution but at least fixes the output:

-$sql = "select * from events where event_tstamp >= $from order by event_tstamp desc";
+$sql = "select distinct * from events where event_tstamp >= $from order by event_tstamp desc";
Comment by Juergen Daubert (jue) - Saturday, 11 September 2010, 13:13 GMT
Thanks, tried this today but it doesn't work, the multiple entries are still there
Comment by Jose V Beneyto (sepen) - Saturday, 18 September 2010, 08:55 GMT
this one worked and dups are gone:

-$sql = "select * from events where event_tstamp >= $from order by event_tstamp desc";
+$sql = "select distinct event_date, event_description, event_notes, event_type, event_time from events where event_tstamp >= $from order by event_tstamp desc";
Comment by Juergen Daubert (jue) - Saturday, 18 September 2010, 09:11 GMT
Thanks Jose, I've applied your fix, it works just fine. Not sure if we should try to fix the cause of the duplicates in tlcacher.php?
Comment by Jose V Beneyto (sepen) - Saturday, 18 September 2010, 09:41 GMT
sure, and IMHO we should keep this ticket still as open

also there are some things that could be improved too:

- fix flyspray entries
every new task line is preceded by a 'modified' line like this:
19:23 New task 651 opened by sepen: [pekwm] new version 0.1.12 available
19:23 Task 651 modified by sepen
also we could try to use the $realname provided by flyspray instead of the $nickname

- markup for FS#$BUG_ID
20:50 b091..b2c0 committed by Juergen Daubert: zlib: fix for  FS#588 
in the line above,  FS#588  could be replaced by:
Task <a class='urllink' href='http://crux.nu/bugs/?do=details&amp;task_id=588' title='' rel='nofollow'>588</a>

- markup for [notify] lines:
we could point every notify line to his mailinglist URL
Comment by Thomas Penteker (teK) - Friday, 15 March 2013, 00:27 GMT
Hello Jose,

I implemented your suggestions for real names to be attached to flyspray
logs in our timelines (instead of nicknames) and rebuilt the whole timeline.db
to reflect this change. Enjoy ;)

Loading...