CRUX

Welcome to CRUX bug tracking.
Tasklist

FS#594 - allow setting the locale in /etc/rc.conf

Attached to Project: CRUX
Opened by Benedikt Müller (linopolus) - Monday, 24 May 2010, 10:27 GMT
Last edited by Jose V Beneyto (sepen) - Thursday, 08 July 2010, 10:06 GMT
Task Type Feature Request
Category tools
Status Closed
Assigned To No-one
Operating System Linux
Severity Low
Priority Normal
Reported Version Development
Due in Version 2.7
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Hi
It's a mess to set the locale (LC_* and LANG variables) in CRUX 2.6. It would be great, if it could be as simple as adding LOCALE="en_US.utf8" (for example) to the /etc/rc.conf.

Benedikt
This task depends upon

Closed by  Jose V Beneyto (sepen)
Thursday, 08 July 2010, 10:06 GMT
Reason for closing:  Not a bug
Comment by Juergen Daubert (jue) - Tuesday, 25 May 2010, 15:37 GMT
Well, if setting LC* and LANG in profile or the like is a mess, you might have chosen the wrong distribution ;)

Anyway,
- IMO setting LC* or LANG isn't a system task, but should be done by/for each user
- most likely you want different settings for the various LC* variables, at least I'd set LC_COLLATE different
to LC_CTYPE or whatever, so what should be set with the LOCALE variable of rc.conf?
- What's the point in setting LANG, if all nls stuff is removed?
Comment by Benedikt Müller (linopolus) - Tuesday, 25 May 2010, 16:07 GMT
Setting LANG is just a habit.

I'd set LC_ALL via rc.conf.

IMO setting it is a system task, but I think it's a matter of taste.
Comment by Jose V Beneyto (sepen) - Thursday, 08 July 2010, 10:05 GMT
Agree with Juergen, +1
And IMHO you should use /etc/rc.local instead of /etc/rc for your personal uses.

Loading...