CRUX

Welcome to CRUX bug tracking.
Tasklist

FS#275 - opt/qt4 fails to work with distcc.

Attached to Project: CRUX
Opened by Danny Rawlins (Romster) - Friday, 16 May 2008, 10:09 GMT
Last edited by Jose V Beneyto (sepen) - Tuesday, 11 May 2010, 06:41 GMT
Task Type Bug Report
Category ports → core/opt
Status Closed
Assigned To Jose V Beneyto (sepen)
Operating System Linux
Severity Low
Priority Normal
Reported Version 2.6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

opt/qt4 fails to work with distcc.

g++ -c -o msvc_vcproj.o -pipe -DQMAKE_OPENSOURCE_EDITION -O2 -march=i686 -pipe -I. -Igenerators -Igenerators/unix -Igenerators/win32 -Igenerators/mac -I/usr/ports/opt/qt4-new/work/src/qt-x11-opensource-src-4.4.0/include -I/usr/ports/opt/qt4-new/work/src/qt-x11-opensource-src-4.4.0/include/QtCore -I/usr/ports/opt/qt4-new/work/src/qt-x11-opensource-src-4.4.0/include -I/usr/ports/opt/qt4-new/work/src/qt-x11-opensource-src-4.4.0/include/QtCore -I/usr/ports/opt/qt4-new/work/src/qt-x11-opensource-src-4.4.0/src/corelib/global -I/usr/ports/opt/qt4-new/work/src/qt-x11-opensource-src-4.4.0/src/script -DQT_NO_PCRE -DQT_NO_TEXTCODEC -DQT_NO_UNICODETABLES -DQT_NO_COMPONENT -DQT_NO_STL -DQT_BUILD_QMAKE -DQT_NO_COMPRESS -I/usr/ports/opt/qt4-new/work/src/qt-x11-opensource-src-4.4.0/mkspecs/linux-g++ -DHAVE_QCONFIG_CPP -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_GEOM_VARIANT generators/win32/msvc_vcproj.cpp
distcc[11231] (dcc_select_for_read) ERROR: IO timeout
distcc[11231] (dcc_r_token_int) ERROR: read failed while waiting for token "DONE"
distcc[11231] Warning: failed to distribute /var/cache/ccache/unixmake2.tmp.arkanoid.11211.ii to fire, running locally instead
distcc[11232] (dcc_select_for_read) ERROR: IO timeout
distcc[11232] (dcc_r_token_int) ERROR: read failed while waiting for token "DONE"
distcc[11232] Warning: failed to distribute /var/cache/ccache/unixmake.tmp.arkanoid.11215.ii to space, running locally instead
This task depends upon

Closed by  Jose V Beneyto (sepen)
Tuesday, 11 May 2010, 06:41 GMT
Reason for closing:  Works for me
Comment by Johannes Winkelmann (jw) - Friday, 16 May 2008, 20:56 GMT
Strange, I can't reproduce any IO timeout errors, using the following setup:
- two compile hosts, one with qt4 installed, one without
- -j5

could you provide a log file from distccd (--verbose --log-file=/tmp/distccd.log) for this error?
Comment by Johannes Winkelmann (jw) - Friday, 16 May 2008, 20:57 GMT
I can reproduce the following:

cc1: error: .pch/release-shared/QtCore: No such file or directory
distcc[22268] ERROR: compile ../3rdparty/harfbuzz/src/harfbuzz.c on titanium failed


This is caused by the use of precompiled headers; that one can be disabled in configure, I want to play around a bit more though
Comment by Johannes Winkelmann (jw) - Friday, 16 May 2008, 21:05 GMT
for those interested, add -no-pch to the configure line; note that disabling precompiled headers will make non-distributed builds slower; I'll investigate into the difference in time before making the final call on that one
Comment by Johannes Winkelmann (jw) - Friday, 16 May 2008, 21:07 GMT
Relevant: http://www.linuxfromscratch.org/pipermail/blfs-dev/2005-August/011026.html

qt3 build takes 22 instead of 37 minutes to build when using PCH...
Comment by Danny Rawlins (Romster) - Saturday, 17 May 2008, 14:28 GMT
OK , -no-pch allows me to compile on distcc.
Comment by Johannes Winkelmann (jw) - Saturday, 17 May 2008, 15:10 GMT
Okay, then the IO timeout error was probably independent from qt4
Comment by Johannes Winkelmann (jw) - Thursday, 19 June 2008, 06:00 GMT
a patch was submitted against distcc to support PCH, so we can expect a solution soon
Comment by Jose V Beneyto (sepen) - Friday, 12 March 2010, 08:28 GMT
I'm not using distcc, could someone verify the ticket against our current version of opt/qt4 (4.6.1)
Comment by Jose V Beneyto (sepen) - Friday, 07 May 2010, 23:12 GMT
same for version 4.6.2?

Loading...