CRUX

Welcome to CRUX bug tracking.
Tasklist

FS#1913 - Opt/polkit-121 requires update of mozjs78 to mozjs91

Attached to Project: CRUX
Opened by Richard Dunbar (cardinal) - Monday, 18 July 2022, 16:21 GMT
Last edited by Tim Biermann (tb) - Sunday, 28 August 2022, 10:44 GMT
Task Type Bug Report
Category ports
Status Closed
Assigned To No-one
Operating System CRUX
Severity Medium
Priority Normal
Reported Version 3.6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Update to polkit-121 fails during configure:
Run-time dependency mozjs-91 found: NO (tried pkgconfig and cmake)
polkit-v.121/meson.build:150:2: ERROR: Dependency "mozjs-91" not found, tried pkgconfig and cmake

Opt/mozjs78-78.15.0-1 has to be updated to mozjs91 before polkit-0.120-3 can be updated to polkit-121-1.
This task depends upon

Closed by  Tim Biermann (tb)
Sunday, 28 August 2022, 10:44 GMT
Reason for closing:  Not a bug
Additional comments about closing:  we switched to duktape, mozjs91 will or will not show up in the future
Comment by John McQuah (farkuhar) - Friday, 29 July 2022, 17:08 GMT
Thanks for the bug report, cardinal. The mozjs detection was fixed in the latest polkit commit: https://crux.nu/gitweb/?p=ports/opt.git;a=commit;h=de0fc69d754ae48a24378b0c1b720f5647a9164c

You'll notice that the meson setup now looks for mozjs91, which is not yet available in the official repositories. I've attached a Pkgfile that satisfies the mozjs dependency of polkit, at least on my system. Feel free to use it and create the port mozjs91 in your personal overlay. If you want to prevent the automatic installation of the duktape dependency (no longer needed once mozjs91 is available), you can put the line 'mozjs91: duktape' in /etc/prt-get.aliases.
   Pkgfile (3.8 KiB)
Comment by Richard Dunbar (cardinal) - Monday, 01 August 2022, 22:23 GMT
Thank you for your kind words and additional information.
For an update to mozjs91 I had done a minimal modification of the existing mozjs78 Pkgfile.
   Pkgfile (0.7 KiB)

Loading...