CRUX

Welcome to CRUX bug tracking.
Tasklist

FS#1813 - firefox-bin: suppress erroneous revdep report

Attached to Project: CRUX
Opened by Daryl Fonseca-Holt (wyatt) - Saturday, 27 June 2020, 21:09 GMT
Last edited by Fredrik Rinnestam (frinnst) - Sunday, 28 June 2020, 13:37 GMT
Task Type Improvement
Category ports → core/opt
Status Closed
Assigned To Fredrik Rinnestam (frinnst)
Operating System CRUX
Severity Low
Priority Normal
Reported Version 3.5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Please add:
install -d $PKG/etc/ld.so.conf.d
echo "/usr/lib/firefox" > $PKG/etc/ld.so.conf.d/firefox.conf
to Pkgfile

Thanks for al the great CRUX!
This task depends upon

Closed by  Fredrik Rinnestam (frinnst)
Sunday, 28 June 2020, 13:37 GMT
Reason for closing:  Invalid
Comment by Fredrik Rinnestam (frinnst) - Saturday, 27 June 2020, 22:54 GMT
echo "/usr/lib/firefox" > $PKG/etc/revdep.d/firefox-bin

is already in the port and I cannot reproduce your error - revdep returns clean. Don't you have that file?
Comment by Daryl Fonseca-Holt (wyatt) - Saturday, 27 June 2020, 23:36 GMT
Ummm. Never mind. I tried this and the loader gives errors on other programs:
/sbin/ldconfig: /usr/lib/firefox/libxul.so.sig is not an ELF file - it has the wrong magic bytes at the start.
Comment by Fredrik Rinnestam (frinnst) - Sunday, 28 June 2020, 01:50 GMT
the /etc/revdep.d/firefox-bin file should shut revdep up - it doesnt exist on your system?

Loading...