CRUX

Welcome to CRUX bug tracking.
Tasklist

FS#1804 - prt-get does not force reinstalling

Attached to Project: CRUX
Opened by Feodor Petrov (teodor) - Sunday, 12 April 2020, 05:49 GMT
Last edited by Fredrik Rinnestam (frinnst) - Monday, 13 April 2020, 00:19 GMT
Task Type Bug Report
Category tools → prt-get
Status Closed
Assigned To No-one
Operating System CRUX
Severity Low
Priority Normal
Reported Version 3.5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Options -fr and -f don't work.
It just says that package is installed.

Or I missunderstand something?
This task depends upon

Closed by  Fredrik Rinnestam (frinnst)
Monday, 13 April 2020, 00:19 GMT
Reason for closing:  Invalid
Comment by Feodor Petrov (teodor) - Sunday, 12 April 2020, 07:03 GMT
Hmm. when using 'update' it reinstalls even whithout -f and -fr.
When using 'install' it does not reinstall whith -fr -f.
Comment by Feodor Petrov (teodor) - Sunday, 12 April 2020, 14:01 GMT
The problem is bigger that it seems. Trying to make depinst on installed package for updating purposes fails.
Comment by Tim Biermann (tb) - Sunday, 12 April 2020, 14:59 GMT
> Or I missunderstand something?
Without ill intend, I guess that's it.

depinst is just to install.
update is for updating/rebuilding. add -fr to update to force rebuild. -f tells pkgadd to apply force on adding a package if your package tries to add files that are owned by another package.
Comment by Feodor Petrov (teodor) - Sunday, 12 April 2020, 15:24 GMT
> depinst is just to install.
And how to update package with it's new dependencies? Just 'update' and it will resolve all dependencies?
Comment by Tim Biermann (tb) - Sunday, 12 April 2020, 16:43 GMT
No, it just won't do that. core/opt/contrib/xorg usually announces new/changed dependencies over the ml, else you need to check with deptree in question.

Loading...