CRUX-Contrib

Contributed ports (contrib collection)
Tasklist

FS#1759 - Compilation of libdbusmenu-gtk3 failed

Attached to Project: CRUX-Contrib
Opened by Cédric Macquat (Rocket) - Monday, 12 August 2019, 16:41 GMT
Last edited by Tim Biermann (tb) - Friday, 16 August 2019, 08:02 GMT
Task Type Bug Report
Category ports - contrib
Status Closed
Assigned To Tim Biermann (tb)
Operating System CRUX
Severity Low
Priority Normal
Reported Version 3.5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The compilation of libdbusmenu-gtk3 failed:

--------------------
prt-get: updating /usr/ports/contrib/libdbusmenu-gtk3
=======> Building '/usr/ports/contrib/libdbusmenu-gtk3/libdbusmenu-gtk3#18.10-1.pkg.tar.gz'.
bsdtar -p -o -C /usr/ports/contrib/libdbusmenu-gtk3/work/src -xf /usr/ports/contrib/libdbusmenu-gtk3/libdbusmenu_18.10.20180917~bzr490+repack1.orig.tar.xz
cp 0001_no-deprecated-gnome-common-macros.patch /usr/ports/contrib/libdbusmenu-gtk3/work/src
+ build
+ cd libdbusmenu-18.10.20180917~bzr490
+ patch -Np1 -i /usr/ports/contrib/libdbusmenu-gtk3/work/src/0001_no-deprecated-gnome-common-macros.patch
patching file autogen.sh
+ sed -e 's/gtkdocize || exit 1//g' -i autogen.sh
+ sed -e s/--enable-gtk-doc//g -i autogen.sh
+ sed -e s/AM_MAINTAINER_MODE//g -i configure.ac
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/libdbusmenu-gtk3 --localstatedir=/var --with-gtk=3
which: no gnome-autogen.sh in (/home/usr/bin:/home/usr/bin/scripts:/bin:/usr/bin:/opt/bin:/usr/local/bin:/home/usr/bin/scripts)
You need gnome-common from GNOME SVN
=======> ERROR: Building '/usr/ports/contrib/libdbusmenu-gtk3/libdbusmenu-gtk3#18.10-1.pkg.tar.gz' failed.

-- Packages where update failed
libdbusmenu-gtk3
-------------------

Is the problem the missing dependency "gnome-common" ?

This task depends upon

Closed by  Tim Biermann (tb)
Friday, 16 August 2019, 08:02 GMT
Reason for closing:  Not a bug
Comment by Tim Biermann (tb) - Wednesday, 14 August 2019, 17:52 GMT
Hi Cédric,
pretty much should be it, please install gnome-common and try to compile it.
Comment by Tim Biermann (tb) - Friday, 16 August 2019, 08:01 GMT
I can not reproduce this in a clean environment. prt-get depinst libdbusmenu-gtk3 produces this output: http://dpaste.com/0AGAAN8

libdbusmenu-gtk3 depends on libdbusmenu-glib, libdbusmenu-glib will pull in gnome-common. Please use prt-get depinst.

Loading...