CRUX

Welcome to CRUX bug tracking.
Tasklist

FS#1698 - CRUX 3.3 or 3.4 installation cd / usb can't mount efivarfs, and thus i can't use efibootmgr to fix..

Attached to Project: CRUX
Opened by matti christensen (mc) - Friday, 16 November 2018, 18:11 GMT
Last edited by Matt Housh (jaeger) - Tuesday, 20 November 2018, 06:04 GMT
Task Type Bug Report
Category ISO
Status Closed
Assigned To Matt Housh (jaeger)
Operating System CRUX
Severity Medium
Priority Normal
Reported Version 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello

Been w you from 2.7 and it has been a joy :-)

Now i have an issue w macbook4.1 and to handle it i ought to use efibootmgr when booting w installation usb disk. Unfortunately i'm unable to as efivarfs is not mounted at boot time. i'm also unable to mount efivarfs manually or load efivarfs kernel module.

Hope to hear from you.
This task depends upon

Closed by  Matt Housh (jaeger)
Tuesday, 20 November 2018, 06:04 GMT
Reason for closing:  Not a bug
Comment by Matt Housh (jaeger) - Friday, 16 November 2018, 21:37 GMT
Hello, Matti,

Glad to hear you like CRUX and have been around quite a while!

Can you provide some more details for the efivarfs issue? What error(s) do you see when using efibootmgr? What error(s) do you see when you try to load the efivarfs kernel module or mount efivarfs?
Comment by matti christensen (mc) - Saturday, 17 November 2018, 16:33 GMT
ok - see attached files and note that i have two macbooks and i lied to you :-( macbook2.1 EMC2139 is the older of which these files and this issue are from - core 2 2x2ghz / 945xx chipset / gma950


-- 'dmesg_macbook21_older.out' please note - "efi: No EFI runtime due to 32/64-bit mismatch with kernel"

-- 'crux34_install_fstab' installation media fstab has line for efivarfs

-- 'launc_efibootmgr_macbook21_older.err'

-- 'modprobe_efivarfs_macbook21_older.out'

-- 'mount_efivarfs_macbook21_older.out'

/mc
Comment by Matt Housh (jaeger) - Sunday, 18 November 2018, 00:39 GMT
Thanks for the files. Looks like you're running into the problem of the first few models of intel macs which support 64-bit operating systems but use a 32-bit UEFI. I don't have one of these to test myself so I don't know how to solve the problem for sure. You *might* be able to use the BIOS fallback style boot that bootcamp would use for windows, or try booting one of the ISOs from here: https://mattgadient.com/2016/07/11/linux-dvd-images-and-how-to-for-32-bit-efi-macs-late-2006-models/

If one of those works (meaning you can boot from it and use efibootmgr), maybe we could learn from it how that is accomplished. If you were able to boot from one of those, it could be used to install CRUX.
Comment by matti christensen (mc) - Sunday, 18 November 2018, 12:06 GMT

because this issue is not a bug i'll continue discussion on mailing list ( which i ought to have done in the first place ) after finding a suitable one
Comment by Matt Housh (jaeger) - Tuesday, 20 November 2018, 06:04 GMT
OK. If it turns out to be something we can easily fix we can reopen or pursue as needed.

Loading...