CRUX

Welcome to CRUX bug tracking.
Tasklist

FS#1676 - wine will not install

Attached to Project: CRUX
Opened by Francisco Carvalho (fpcarv) - Tuesday, 24 July 2018, 20:55 GMT
Last edited by Fredrik Rinnestam (frinnst) - Friday, 24 August 2018, 18:25 GMT
Task Type Bug Report
Category ports
Status Closed
Assigned To Danny Rawlins (Romster)
Operating System CRUX
Severity Low
Priority Normal
Reported Version 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

-- wine port --

- fresh CRUX 3.4 install,

- installed the freetype port

- Made all changes as proposed at the README file of the wine port

- The build fails with the message:

checking for -lfreetype... not found
configure: error: FreeType 32-bit developement files not found. Fonts will not be built.
Use the --without-freetype option if you really want this

This task depends upon

Closed by  Fredrik Rinnestam (frinnst)
Friday, 24 August 2018, 18:25 GMT
Reason for closing:  Not a bug
Comment by Fredrik Rinnestam (frinnst) - Tuesday, 24 July 2018, 22:37 GMT
did you run "prt-get depinst wine"?
Comment by Francisco Carvalho (fpcarv) - Friday, 24 August 2018, 15:28 GMT

Yes ... done that ... it went fine.

freetype32 is not included in the dependencies, but I've installed it directly from the ports/compat-32/freetype-32 folder.

However, when later, I run pkgmk for wine it breaks while compiling x11drv_main.c at ../src/wine32/dlls/winex11.drv

Comment by Fredrik Rinnestam (frinnst) - Friday, 24 August 2018, 18:25 GMT
You must not have used depinst when installing fontconfig-32 then. fontconfig-32 depends on freetype-32 so a depinst should have installed it all. Ofcourse, if you dont use depinst while installing fontconfig-32 it would fail to install freetype-32.

Loading...