CRUX

Welcome to CRUX bug tracking.
Tasklist

FS#1672 - [qt5] No cmake files in the package

Attached to Project: CRUX
Opened by Predrag Ivanovic (pedja) - Tuesday, 26 June 2018, 22:39 GMT
Last edited by Predrag Ivanovic (pedja) - Tuesday, 03 July 2018, 16:01 GMT
Task Type Bug Report
Category ports → core/opt
Status Closed
Assigned To Danny Rawlins (Romster)
Operating System CRUX
Severity High
Priority Normal
Reported Version 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

As reported in #crux by tsaop@, and confirmed by me,
qt5 package currently ships without cmake files, which
breaks any application that is using cmake to find and build against Qt5.

Likely culprit is 'fix missing includes' in the Pkgfile, since
after removng it and rebuilding qt5, few applications I tried
build fine, since cmake files are there after that.

It is no longer needed, since it was fixed upstream
(https://bugreports.qt.io/browse/QTBUG-37417)
Trivial patch (just the Pkgfile) attached.
This task depends upon

Closed by  Predrag Ivanovic (pedja)
Tuesday, 03 July 2018, 16:01 GMT
Reason for closing:  Fixed

Loading...