CRUX

Welcome to CRUX bug tracking.
Tasklist

FS#141 - Some ports fail to compile with make -jX

Attached to Project: CRUX
Opened by Fredrik Rinnestam (rehabdoll) - Tuesday, 21 November 2006, 13:16 GMT
Last edited by Fredrik Rinnestam (frinnst) - Tuesday, 03 February 2015, 20:53 GMT
Task Type Bug Report
Category ports → core/opt
Status Closed
Assigned To CRUX Developers (crux)
Operating System CRUX
Severity Very Low
Priority Normal
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

autoconf, groff, gzip and mktemp all fails to build on my system with \"MAKEFLAGS=-j5\". A possible and simple solution would be to inject the -j1 flag in the Pkgfile of the ports affected.

I\'ve not yet tested if there are any ports in opt that fail with -jX, but i expect there are.
This task depends upon

Closed by  Fredrik Rinnestam (frinnst)
Tuesday, 03 February 2015, 20:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  New ports pop up once in a while with race conditions. These are detected and fixed independently of this bugreport. Closing.
Comment by Fredrik Rinnestam (rehabdoll) - Wednesday, 28 February 2007, 23:42 GMT
Just noticed that not all of gcc gets packaged with -j3.

=======> ERROR: Footprint mismatch found:
MISSING drwxr-xr-x root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/objc/
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/objc/NXConstStr.h
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/objc/Object.h
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/objc/Protocol.h
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/objc/encoding.h
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/objc/hash.h
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/objc/objc-api.h
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/objc/objc-decls.h
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/objc/objc-list.h
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/objc/objc.h
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/objc/sarray.h
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/objc/thr.h
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/objc/typedstream.h
MISSING drwxr-xr-x root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/ssp/
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/ssp/ssp.h
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/ssp/stdio.h
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/ssp/string.h
MISSING -rw-r--r-- root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/ssp/unistd.h
=======> ERROR: Building \'/usr/ports/pkg/gcc#4.1.2-1.pkg.tar.gz\' failed.
Comment by Matt Housh (jaeger) - Wednesday, 02 May 2007, 15:50 GMT
Some others that fail with -jX some or all of the time:

opt/cdparanoia
opt/cyrus-sasl
opt/samba
opt/nss
opt/ghostscript
Comment by Juergen Daubert (jue) - Saturday, 28 July 2007, 08:11 GMT
Fixed for autoconf, groff, mktemp, cdparanoia, samba and ghostscript.
Cannot reproduce for gzip.
Comment by Fredrik Rinnestam (rehabdoll) - Monday, 24 September 2007, 23:39 GMT
opt/mod_php
reported by "qid"
Comment by Fredrik Rinnestam (rehabdoll) - Saturday, 24 November 2007, 22:53 GMT
"make -j1 install" in gcc's Pkgfile fixes my footprint errors.
Comment by Tilman Sauerbeck (tilman) - Saturday, 03 May 2008, 10:36 GMT
See this thread on a possible solution to catch these errors earlier: http://lists.crux.nu/pipermail/crux-devel/2008-May/003386.html
Comment by Tilman Sauerbeck (tilman) - Sunday, 20 July 2008, 20:58 GMT
opt/subversion needs -j 1 at the install stage, too.

(I'll handle this myself if Simone doesn't get a chance to fix it)
Comment by Tilman Sauerbeck (tilman) - Friday, 01 August 2008, 16:20 GMT
I fixed the one in subversion.
Comment by Fredrik Rinnestam (rehabdoll) - Sunday, 23 November 2008, 19:21 GMT
sudo 1.6.9p18 failed for me. -j1 on install seems to fix it.
Comment by Fredrik Rinnestam (rehabdoll) - Sunday, 23 November 2008, 19:22 GMT
I also noticed while building x86_64 iso's that ncurses also seems to have some issues.
Comment by Giuseppe Coviello (cjg) - Tuesday, 17 March 2009, 22:38 GMT
Also xfsprogs should be built with -j1.

I think that this bug report should be reassigned to someone else than sip, since he's a retired maintainer as I can see from http://crux.nu/Main/RetiredMembers.
Comment by Juergen Daubert (jue) - Wednesday, 18 March 2009, 10:00 GMT
Fixed for xfsprogs.
Comment by Fredrik Rinnestam (rehabdoll) - Monday, 14 September 2009, 00:57 GMT
noticed that net-tools needs -j1 when building a 64bit iso.

Loading...